Failed to restart Apache2

The name of the pictureThe name of the pictureThe name of the pictureClash Royale CLAN TAG#URR8PPP








up vote
0
down vote

favorite












I get this error



/etc/init.d/apache2: 46: .: Can't open /etc/apache2/envvars
[....] Restarting apache2 (via systemctl): apache2.serviceJob for apache2.service failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xe" for details.
failed!


when i run



[apachectl configtest]


it shows
apache2: Could not open configuration file /etc/apache2/apache2.conf: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.







share|improve this question


















  • 2




    So does the file exist? Please check!
    – George Udosen
    Apr 21 at 16:56










  • Have you removed /etc/apache2 or something similar, as it complains about multiple missing files?
    – vidarlo
    Apr 21 at 17:09










  • when i ran [ systemctl status apache2.service] it shows systemd[1]: Failed to start The Apache HTTP Server.
    – utshomomen
    Apr 21 at 17:25















up vote
0
down vote

favorite












I get this error



/etc/init.d/apache2: 46: .: Can't open /etc/apache2/envvars
[....] Restarting apache2 (via systemctl): apache2.serviceJob for apache2.service failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xe" for details.
failed!


when i run



[apachectl configtest]


it shows
apache2: Could not open configuration file /etc/apache2/apache2.conf: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.







share|improve this question


















  • 2




    So does the file exist? Please check!
    – George Udosen
    Apr 21 at 16:56










  • Have you removed /etc/apache2 or something similar, as it complains about multiple missing files?
    – vidarlo
    Apr 21 at 17:09










  • when i ran [ systemctl status apache2.service] it shows systemd[1]: Failed to start The Apache HTTP Server.
    – utshomomen
    Apr 21 at 17:25













up vote
0
down vote

favorite









up vote
0
down vote

favorite











I get this error



/etc/init.d/apache2: 46: .: Can't open /etc/apache2/envvars
[....] Restarting apache2 (via systemctl): apache2.serviceJob for apache2.service failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xe" for details.
failed!


when i run



[apachectl configtest]


it shows
apache2: Could not open configuration file /etc/apache2/apache2.conf: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.







share|improve this question














I get this error



/etc/init.d/apache2: 46: .: Can't open /etc/apache2/envvars
[....] Restarting apache2 (via systemctl): apache2.serviceJob for apache2.service failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xe" for details.
failed!


when i run



[apachectl configtest]


it shows
apache2: Could not open configuration file /etc/apache2/apache2.conf: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.









share|improve this question













share|improve this question




share|improve this question








edited Apr 21 at 16:55









George Udosen

17k93559




17k93559










asked Apr 21 at 16:46









utshomomen

1




1







  • 2




    So does the file exist? Please check!
    – George Udosen
    Apr 21 at 16:56










  • Have you removed /etc/apache2 or something similar, as it complains about multiple missing files?
    – vidarlo
    Apr 21 at 17:09










  • when i ran [ systemctl status apache2.service] it shows systemd[1]: Failed to start The Apache HTTP Server.
    – utshomomen
    Apr 21 at 17:25













  • 2




    So does the file exist? Please check!
    – George Udosen
    Apr 21 at 16:56










  • Have you removed /etc/apache2 or something similar, as it complains about multiple missing files?
    – vidarlo
    Apr 21 at 17:09










  • when i ran [ systemctl status apache2.service] it shows systemd[1]: Failed to start The Apache HTTP Server.
    – utshomomen
    Apr 21 at 17:25








2




2




So does the file exist? Please check!
– George Udosen
Apr 21 at 16:56




So does the file exist? Please check!
– George Udosen
Apr 21 at 16:56












Have you removed /etc/apache2 or something similar, as it complains about multiple missing files?
– vidarlo
Apr 21 at 17:09




Have you removed /etc/apache2 or something similar, as it complains about multiple missing files?
– vidarlo
Apr 21 at 17:09












when i ran [ systemctl status apache2.service] it shows systemd[1]: Failed to start The Apache HTTP Server.
– utshomomen
Apr 21 at 17:25





when i ran [ systemctl status apache2.service] it shows systemd[1]: Failed to start The Apache HTTP Server.
– utshomomen
Apr 21 at 17:25











1 Answer
1






active

oldest

votes

















up vote
0
down vote













apachectl told you that he can't open apache configuration file.



With help of the following command:



whoami
ls -la /etc/apache2/apache2.conf


check if file exists and file permissions.



In addition you could list and cat apache2 logs file in /var/logs/apache2






share|improve this answer
















  • 1




    Both /etc/apache2/envvars and /etc/apache2/apache2.conf is missing according to the output. envvars is not typically something you change. It sounds like either a install interrupted in the middle, or a manual removal of config files.
    – vidarlo
    Apr 22 at 10:13










Your Answer







StackExchange.ready(function()
var channelOptions =
tags: "".split(" "),
id: "89"
;
initTagRenderer("".split(" "), "".split(" "), channelOptions);

StackExchange.using("externalEditor", function()
// Have to fire editor after snippets, if snippets enabled
if (StackExchange.settings.snippets.snippetsEnabled)
StackExchange.using("snippets", function()
createEditor();
);

else
createEditor();

);

function createEditor()
StackExchange.prepareEditor(
heartbeatType: 'answer',
convertImagesToLinks: true,
noModals: false,
showLowRepImageUploadWarning: true,
reputationToPostImages: 10,
bindNavPrevention: true,
postfix: "",
onDemand: true,
discardSelector: ".discard-answer"
,immediatelyShowMarkdownHelp:true
);



);













 

draft saved


draft discarded


















StackExchange.ready(
function ()
StackExchange.openid.initPostLogin('.new-post-login', 'https%3a%2f%2faskubuntu.com%2fquestions%2f1026992%2ffailed-to-restart-apache2%23new-answer', 'question_page');

);

Post as a guest






























1 Answer
1






active

oldest

votes








1 Answer
1






active

oldest

votes









active

oldest

votes






active

oldest

votes








up vote
0
down vote













apachectl told you that he can't open apache configuration file.



With help of the following command:



whoami
ls -la /etc/apache2/apache2.conf


check if file exists and file permissions.



In addition you could list and cat apache2 logs file in /var/logs/apache2






share|improve this answer
















  • 1




    Both /etc/apache2/envvars and /etc/apache2/apache2.conf is missing according to the output. envvars is not typically something you change. It sounds like either a install interrupted in the middle, or a manual removal of config files.
    – vidarlo
    Apr 22 at 10:13














up vote
0
down vote













apachectl told you that he can't open apache configuration file.



With help of the following command:



whoami
ls -la /etc/apache2/apache2.conf


check if file exists and file permissions.



In addition you could list and cat apache2 logs file in /var/logs/apache2






share|improve this answer
















  • 1




    Both /etc/apache2/envvars and /etc/apache2/apache2.conf is missing according to the output. envvars is not typically something you change. It sounds like either a install interrupted in the middle, or a manual removal of config files.
    – vidarlo
    Apr 22 at 10:13












up vote
0
down vote










up vote
0
down vote









apachectl told you that he can't open apache configuration file.



With help of the following command:



whoami
ls -la /etc/apache2/apache2.conf


check if file exists and file permissions.



In addition you could list and cat apache2 logs file in /var/logs/apache2






share|improve this answer












apachectl told you that he can't open apache configuration file.



With help of the following command:



whoami
ls -la /etc/apache2/apache2.conf


check if file exists and file permissions.



In addition you could list and cat apache2 logs file in /var/logs/apache2







share|improve this answer












share|improve this answer



share|improve this answer










answered Apr 22 at 7:06









boly38

1434




1434







  • 1




    Both /etc/apache2/envvars and /etc/apache2/apache2.conf is missing according to the output. envvars is not typically something you change. It sounds like either a install interrupted in the middle, or a manual removal of config files.
    – vidarlo
    Apr 22 at 10:13












  • 1




    Both /etc/apache2/envvars and /etc/apache2/apache2.conf is missing according to the output. envvars is not typically something you change. It sounds like either a install interrupted in the middle, or a manual removal of config files.
    – vidarlo
    Apr 22 at 10:13







1




1




Both /etc/apache2/envvars and /etc/apache2/apache2.conf is missing according to the output. envvars is not typically something you change. It sounds like either a install interrupted in the middle, or a manual removal of config files.
– vidarlo
Apr 22 at 10:13




Both /etc/apache2/envvars and /etc/apache2/apache2.conf is missing according to the output. envvars is not typically something you change. It sounds like either a install interrupted in the middle, or a manual removal of config files.
– vidarlo
Apr 22 at 10:13

















 

draft saved


draft discarded















































 


draft saved


draft discarded














StackExchange.ready(
function ()
StackExchange.openid.initPostLogin('.new-post-login', 'https%3a%2f%2faskubuntu.com%2fquestions%2f1026992%2ffailed-to-restart-apache2%23new-answer', 'question_page');

);

Post as a guest













































































Popular posts from this blog

Which professions warranted travel in Medieval times?

How do so many people here on Academia.SE, and in general, afford lavish higher education programs?

Trouble downloading packages list due to a “Hash sum mismatch” error